Some issue with Loyverse Back Office
Incident Report for Loyverse
Resolved
The temporary technical issue has been resolved
Posted Nov 18, 2022 - 04:22 UTC
Investigating
We’re having some issue with Loyverse Back Office . We’re working to solve the problem as quickly as we can.
Posted Nov 18, 2022 - 02:52 UTC
This incident affected: Loyverse POS, Loyverse Back Office, and Loyverse API.