Temporary issue with Loyverse Back Office
Incident Report for Loyverse
Resolved
Our team has made improvements, please reload the Back Office and try again.
Posted Mar 20, 2024 - 11:15 UTC
Monitoring
Our team has made improvements, please reload the Back Office and try again.
Posted Mar 20, 2024 - 09:57 UTC
Investigating
We’re having some technical difficulties with the Loyverse Back Office .

Our team is already working to solve the problem as quickly as we can.

You can still make sales during this time and all data will sync with the back office later
Posted Mar 20, 2024 - 09:45 UTC
This incident affected: Loyverse Back Office.